User talk:Orso

From Vectorlab
Jump to: navigation, search

Wiki Previewer

Hi Orso,

Thank you.

Gerard

You're welcome Gerard! I hope you're going to enjoy it. --orso 08:15, 2 September 2006 (PDT)

Loader

Hi Orso,

I noticed you changed the Text Object Incrementer article to use Loader, for the code of the snippets. Seems to work great. Thanks.

Gerard

Now if you go on Edit then click on VSS pre loader is working by default: try to select some text then click on that. The selected text will wrap on a loader tag.
Loader will one day allow us to download the script on click. A similar behaviour of the loader type=applescript (check any of the applescript examples). But I still cannot figure out how. I'm skimming all conceivable IANA protocols to find something usable AND secure, as we have with the applescript:// url locator. But I cannot yet find it. Either they are useless or they are unsecure. I must also think about the win users. It is not as easy for them as it is for Mac, where you never give a thought to "security issues".
Currently loader type=vss do only the following:
  • strive to make a common style for vss scripts on vcor, in order to increase readability:
    a space after every comma:
    myFunction(x,y,z) becomes <code=vss>myFunction(x, y, z)</code=vss>
    a space before and after every ":=":
    n:=myFunction(x,y,z) becomes <code=vss>n := myFunction(x, y, z)</code=vss>
    and then -bless it!- this issue of pre is provisorily resolved: every tab expands to 4 spaces. Mind that this has some drawbacks: if a user copies the snippet, he'll have to entab the script. If a tab is part of the script, like
    concat('one', ' ', 'two', ' ', 'three'), which is actually a bad script, chr(9) should be used instead, but can happen, the script will fail. Let think of the case of File I/O operations. But this will be easy to fix with some better grepping.
  • create a Geshi object for the script snippet and apply it. This achieves:
    Keywords camelcase: inSertenHancEdpulLdOwnMenuitem becomes InsertEnhancedPullDownMenuItem, which on my opinion is a better way to write it.
    Keywords syntax highlight.

Let's smoke one together? (LOL!) --orso 19:26, 18 February 2007 (PST)

OK, But we do it on your page. Would you mind much, if I let mine burn in the ashtray? Gerard 05:08, 19 February 2007 (PST)

no problem! I can smoke two at the same time! --orso 22:01, 18 February 2007 (PST)

I like the idea of a code formatter in addition to syntax coloring. One thing I'd like to see is title caps for function names. It's been quite some time since I have used all caps formatting. Perhaps I'm out of the mainstream here... --Frank 06:05, 19 February 2007 (PST)

Welcome back, Frank, it was a long time!
I like the idea. Curiously enough I was thinking the same today, but with a variation: lets have that option skin dependent and on user preferences. I personally would prefer the "NNA-notation" (which is what we have now). Consider that routine all capital: INSERTENHANCEDPULLDOWNMENUITEM. It makes me dizzy. But I was skimming TechBoard today. Some people obviously prefers capital. They should be able to have it. I tell you straight off, that I am not yet able to achieve this. MediaWiki is a big beast. I just touched the surface. --orso 09:44, 19 February 2007 (PST)